Search

Need a custom module?

Should you have any questions about custom DNN modules or web projects, please let us know

Latest Discussions

V 8.19 compatible with dnn 7,2 by karyn letendre
I deleted the only album within the module and can no longer add albums... I am...
No Image Download Link in 9.2.2 UMGClassicNG by saraharendt
I'm using Ultra Media Gallery version 9.2.2 revision 33966 and the UMGClassicNG ...
Cannot enable view permissions in 9.7 by John Warr
I have tried to enable the "view permissions" option under the "settings" tab in...
UVG converter by Hans Beekman
Hi, Own this module a long time but still struggling with conversions. Tri...
Automatically switch from flash to html5 by Manuela Moosmann
Hi, we got customers who refuse to install flash so we upgraded to UVG6 as it ...

Support Forum

Subject: If MP4 video won't play, check that "mp4" MIME type exists on server
Prev Next
You are not authorized to post a reply.

Page 1 of 212 > >>
Author Messages
Larry Daniele
Posts:58
Golden Member


02/11/2009 4:40 PM  

In UVG 3.0.5 Pro, I set Configuration > Video Encoding > Encoding Strategy to "H264" (since I will only be uploading MP4 videos). 

I uploaded an MP4 video and this went fine. A screenshot was properly created.

However, when I went to play the video, I pressed the Play button and nothing played (although the time for the video (0:05) is displayed correctly).

I went to the Video Information module and clicked the Edit Video icon. The raw file was listed as "DNN.5.210.9MediaModuleOverview.mp4" (the same as the Video Source Original Name). However, when I clicked the "Download this video" link, I got the message:

The page cannot be found.

I checked with the File Manager and found that the file did exist.

So what was the problem? My IIS server did not have a MIME type set for "mp4"! I added an entry:

Extension: mp4
MIME type: video/mpeg
Now everything works fine.

I hope my experience can help others avoid this problem. :-)
Pengtsen R
Posts:13038


02/12/2009 1:54 AM  
Thank you, Larry, I appreciate your post so much.

mp4 is not supported in default by IIS 6+, so everybody who use h264 should add mp4 mime type manually.

by the way, Larry, when set encoding stratege to mp4, UVG still encode you video even you upload a video in mp4 format, please be aware of this.

Pengtsen R
http://www.bizmodules.net
Larry Daniele
Posts:58
Golden Member


02/12/2009 5:38 AM  
I am wondering if this encoding of MP4 files decreases the quality of my original video. If my videos are all "640 x 480" and I have the UVG 3 Configuration "H264 Video Resolution" set to "640 x *", the uploaded video doesn't need any processing, right? Is there anything I can do to minimize any loss of quality in this situation?
Pengtsen R
Posts:13038


02/12/2009 5:40 AM  
what's the average bitrate of your mp4 videos?

and did you check the file size of your own video and uvg-encoded videos? is there any great difference?

Pengtsen R
http://www.bizmodules.net
Larry Daniele
Posts:58
Golden Member


02/12/2009 7:25 AM  
Please see the new thread "26 KB .MP4 file expands to 166 KB when encoded on upload" (http://www.bizmodules.net/Support/tabid/55/forumid/13/postid/12753/view/topic/Default.aspx) for my reply. This issue seemed important enough to start a new thread.
Pengtsen R
Posts:13038


02/14/2009 3:51 AM  
ok.

Pengtsen R
http://www.bizmodules.net
Francis Lapierre
Posts:3
Bronze Member

09/23/2009 10:36 AM  
Don’t forget to restart IIS after adding the MIME
Brian K
Posts:86
Diamond Member

02/15/2011 11:37 PM  
Has anyone else run into the problem of playing mp4 videos even with MIME settings in IIS set? I actually can't play flv files from my web server either...though i didn't know it until now because I've been using Amazon S3 before now.
Pengtsen R
Posts:13038


02/16/2011 7:35 AM  
ensure flv and mp4 are supported in your IIS mime type list, restart it, then it should work.

Pengtsen R
http://www.bizmodules.net
Brian K
Posts:86
Diamond Member

02/16/2011 9:15 AM  
They are both added to IIS and have been through many restarts. Also, I can play them fine on other sites on the same web server, just not my DNN site. I also made sure they are allowable file types, though I don't know if that only applies to uploads or would affect the ability to play as well.
Pengtsen R
Posts:13038


02/17/2011 8:06 AM  
try to direct visit your videos in your browser, for example: http://www.yourdomain.com/path/filename.mp4

does it work?

Pengtsen R
http://www.bizmodules.net
Brian K
Posts:86
Diamond Member

02/17/2011 1:27 PM  
No, they don't play. I get the following error.

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

I get the same error when trying to access .zip, .docx, .html, .wmv, .txt, etc. files as well. They work fine though on other sites on the same server. I have double checked the MIME types. The only files I seem to be able to run are .aspx and image files (png, jpg, gif).
Pengtsen R
Posts:13038


02/18/2011 6:51 AM  
do you host by your self? if so do you have a network manager to check this?

if you have a shared server you can contact your hosting provider.

Pengtsen R
http://www.bizmodules.net
Brian K
Posts:86
Diamond Member

02/18/2011 5:30 PM  
I have a co-located server at a hosting company, so I am pretty much on my own unfortunately.
Brian K
Posts:86
Diamond Member

02/23/2011 1:18 PM  
I discovered that if I change my app pool to classic mode, everything plays fine. Does that help anyone to give me potential fixes? I can't use classic mode because Active Social friendly urls are not working in classic mode.
Pengtsen R
Posts:13038


02/23/2011 6:03 PM  
I belive mime type is not related to your app pool.

you can grant me your server access and I'll try to investigate this issue for you. remember to tell me the url of your video.

Pengtsen R
http://www.bizmodules.net
Leather man
Posts:13
Silver Member

03/01/2011 3:47 AM  
I have to agree with Brian. Once changed to Classic mode, mp4 files started to play.

Cheers
Pengtsen R
Posts:13038


03/01/2011 6:19 AM  
This is weird, I'm not aware of this behavior, if anyone have any information about this please let me know.

Pengtsen R
http://www.bizmodules.net
Brian K
Posts:86
Diamond Member

03/15/2011 9:09 PM  
As an update to this, I had to replace the default DNN url friendly url provider with the iFinity free url rewriter. With that change I was able to play/view these files in Integrated App pool mode.
berk celikyurek
Posts:34
Golden Member

03/06/2012 11:39 PM  
First of all - BIG THANKS to Pengtsen for years of SUPERIOR SUPPORT

having issues with mp4 videos ...
we don't upload to DNN server, our videos are stored in another server
we use the external url method -

videos don't start playing until fully downloaded..
any opinion is appreciated

http://www.radio4by4.com/Media/Videos/TabId/66/VideoId/1401/March-3rd-Dj-Einfach-SWITZERLAND.aspx

You are not authorized to post a reply.
Page 1 of 212 > >>

Forums > Ultra Video Gallery > Support Questions > If MP4 video won't play, check that "mp4" MIME type exists on server