Looking for the old forum?

For topics posted before June 2015, please click here to visit the old support forum. Post your questions in this forum if you have any questions.

Support Forums
PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 13 Nov 2015 03:29 PM by  sublimese
jquery-migrate
 5 Replies
Sort:
You are not authorized to post a reply.
Author Messages


New Member


Posts:6
New Member


--
13 Nov 2015 03:29 PM
    Anytime I use the slideShow component on a page, that page ends up with the following in the header:

    <script src="http://code.jquery.com/jquery-migrate-1.0.0.js" type="text/javascript"></script>


    This ONLY appears after I add the SlideShow component to a page and after I have added at least 1 image to that SlideShow.

    The problem is that the script appears to be hard coded to use HTTP. This is a problem on an HTTPS only site.

    Can you please let me know how to fix this? Can I alter a file and change the link?

    Thanks


    New Member


    Posts:6
    New Member


    --
    14 Nov 2015 11:15 AM
    Also on a gallery page the component adds the following to the page:

    http://s7.addthis.com/js/250/addthis_widget.js
    http://maps.googleapis.com/maps/api/js

    The component appears to hard code http for these links which does not work on an SSL enabled site (browsers will block it from loading)

    Is there a way I can change these to https?


    New Member


    Posts:6
    New Member


    --
    14 Nov 2015 12:00 PM
    I debugged your code for you and found the issue. Please fix and release an update.

    In BizModules.UltraMediaGallery\DisplayCtlBase.cs, the method "FixJQueryCompatibility() you are failing to check for http or https, and instead are always writing out http.

    In your other classes that I have checked that implement this method you are testing for http or https and writing our the correct string accordingly.

    Please fix this bug (and anywhere else this bug appears). Thanks!


    Basic Member


    Posts:240
    Basic Member


    --
    15 Nov 2015 12:30 AM
    The latest 9.8.13 fixed this problem.

    Thanks for your report!


    New Member


    Posts:6
    New Member


    --
    16 Nov 2015 09:48 AM
    Installed 9.8.13 and the problem has been resolved! Thank you kindly!


    Basic Member


    Posts:240
    Basic Member


    --
    22 Nov 2015 07:59 PM
    Always glad to help.
    You are not authorized to post a reply.


    Copyright © 2005-2013 BizModules Contact us