This forum is obsolete

This support forum has been replaced by a news version. You can browse old posts in this forum, but please post your questions to the new forum by clicking on "Support" in the top level menu.

Support Forum
Subject: Amazon RTMP Issue
Prev Next
You are not authorized to post a reply.

Author Messages
kafdmd
Posts:12
Silver Member

11/21/2015 7:15 AM  
When I set the S3 integration to use streaming and I enter my Amazon RTMP URL that video does not work. When I change it to Download and change the URL from the RTMP url it works fine but forces the player to download the video. I cannot determine why it is not streaming. Any help would be awesome!

Using the Amazon tool: http://d1k5ny0m6d4zlj.cloudfront.net/diag/CFStreamingDiag.html it works fine.

When I look in the database the file has http:// instead of rtmp:// is that correct?

Pengtsen R
Posts:13551


11/22/2015 8:06 PM  
That is not correct.

rtmp videos will not be playable if use use http protocal.

How did you add the rtmp video to UVG? did you add with "From internet URL" option?

Pengtsen R
http://www.bizmodules.net
kafdmd
Posts:12
Silver Member

11/23/2015 5:04 AM  
That URL was for a test player for Amazon.

When I link to the RTMP URL it works fine, but I was hoping to be able to upload the file, have it encode, and save it with the RTMP:// URL. Does it not work that way?

I have manually changed in the database all of my uploaded files with the corrected RTMP URL and they all work fine but that seems to be a laborious way to do that or even having to physically link it. But if that is the only way to make it work, then that is what I can do.
kafdmd
Posts:12
Silver Member

11/28/2015 8:15 AM  
Ideally, I would like to be able to upload an already converted video directly to my S3 bucket and have it logged into the database as a RTMP:// file. I have thousands of videos I need to upload and they are already converted, but need to be uploaded to S3. The problem is that I would have to manually enter in every URL into the Link tool within UVG.

Unless, there is another solution.
Pengtsen R
Posts:13551


11/29/2015 10:27 AM  
This solution should work:

1, enable Amazon S3 integration in UVG_Configuration, enter your distribution name and choose appropriate distribution type
2, donot enable Elastic Transcoder, you don't need it.
3, in UVG_Configuration, disable "Re-encode mp4"
4, manually copy your video to portal root/ultravideogallery/yourusername folder.
5, in UVG_AddVideo, you can choose to import video from your server hard disk.
6, choose files you copied in first step, add them to UVG.
7, you should see the added videos in UVG_QueueInspector
8, UVG should process your videos, and upload it to Amazon S3
9, then you should be able to play your videos by cloudfront.

You can try with 1 or 2 videos at first to ensure it does work before copying thousand videos.

If this is too complicated, we can also provide custom development on th is scenerio. We can write a tiny app to manually scan your videos(which are already uploaded to Amazon s3) and add them to UVG.

Pengtsen R
http://www.bizmodules.net
kafdmd
Posts:12
Silver Member

11/29/2015 5:58 PM  
I tried that and it didn't upload to S3. I can give you access, just need your email address.

Basically I need it to do the following:

1. Select File to Upload
2. Upload to S3 with the file and a one frame screen shot image.
3. Save information to SQL table with the rtmp:// URL.

If it will work the way you presented then that will be fine, but I wasn't able to get that to work other than saving it to the folder on the server, but not onto S3 with the RTMP information.
kafdmd
Posts:12
Silver Member

11/29/2015 6:03 PM  
I just sent you an invitation to my site to see if you can get this to work. THANKS!!!!
kafdmd
Posts:12
Silver Member

11/29/2015 6:26 PM  
I have it now uploading the file to S3 and logging it to the sql table, but the URL doesn't have the RTMP:// URL, just the http:// URL.

I can get it to work by changing the URL to the RTMP URL manually in the table under the VideoPath field and then setting the AWS_VIDEOKEY field to NULL.
Pengtsen R
Posts:13551


12/05/2015 8:23 PM  
You can click Contact Us on this page to email us.

Please give me your host password so I can login to check what is wrong.

Pengtsen R
http://www.bizmodules.net
kafdmd
Posts:12
Silver Member

12/07/2015 7:30 PM  
I sent it to you yesterday. Thanks for the help!!
Pengtsen R
Posts:13551


12/09/2015 10:53 AM  
I gave you a reply by email.

Pengtsen R
http://www.bizmodules.net
You are not authorized to post a reply.

Copyright © 2005-2013 BizModules Contact us