This forum is obsolete

This support forum has been replaced by a news version. You can browse old posts in this forum, but please post your questions to the new forum by clicking on "Support" in the top level menu.

Support Forum
Subject: Upload large files in IIS 7
Prev Next
You are not authorized to post a reply.

Page 1 of 212 > >>
Author Messages
Pengtsen R
Posts:13551


02/08/2010 9:04 PM  
On IIS7 there is a 30Mb upload limit by default. To change this refer to this article;
http://www.cyprich.com/2008/06/19/fixing-file-upload-size-limit-in-iis-7/

Adjusting File Size Limit in IIS 7

The problem is that in IIS 7 on Windows 2008 Server, the web application will reject any file that is larger than 30 MB. This is a default limitation of IIS. You can increase the maximum file size by adding the following code to <system.webServer> in the web.config file:

<security>
<requestFiltering>
<requestLimits maxAllowedContentLength=”2000000000″ />
</requestFiltering>
</security>

With the above maxAllowedContentLength, users can upload files that are 2,000,000,000 bytes in size. This setting will work right away without restart IIS services.

Pengtsen R
http://www.bizmodules.net
Bienvenido Cancel
Posts:3
Bronze Member

08/05/2010 3:05 PM  
Hi,
Thank you for this valuable information in an important yet obscure subject. I would like to provide a little bit of additional information for the benefit of the community.
1. After a lot of investigation and trial I came across this post and immediately I pasted the code to my web.config file to find the web site unavailable due to a "500 - Internal server error". After testing I concluded that the text was correct and there were no errors but somehow the quotes were causing the problem. If someone find themselves in the same situation, replace the quotes in the code with manual quotes.
2. One must remember to modify <system.web><httpRuntime>; also in the web.config file.
3. I also read about another limitation, this one is related to UVG, with something called "neatUpload"; also in the web.config file.
Pengtsen R
Posts:13551


08/08/2010 12:58 PM  
Thank you very much for your information, I really appreciate it.

Pengtsen R
http://www.bizmodules.net
James Robinson
Posts:29
Silver Member

04/04/2012 9:33 AM  
I am sorry, but I can't get this code to work. My

system.webserver already has the following:

<security>
<requestFiltering allowDoubleEscaping="true" />
</security>

I am not sure how to add this new code into the webconfig file. I just keep getting 500 internal errors trying everything possible. Can you please provide me the exact code I am supposed to put in the webconfig file?

Thanks
Pengtsen R
Posts:13551


04/05/2012 10:55 PM  
<security>
<requestFiltering>
<requestLimits allowDoubleEscaping="true" maxAllowedContentLength=”2000000000″ />
</requestFiltering>
</security>

Pengtsen R
http://www.bizmodules.net
James Robinson
Posts:29
Silver Member

04/06/2012 7:03 AM  
Hello,

Thank you for the code. Howevever, when I insert the code like you have suggested I receive an a 500 - Internal Error.

I see in the posting above someone who said to put in manual quotes. I do not know what that means. Can you provide me the code with manual quotes?

Thanks
James Robinson
Posts:29
Silver Member

04/09/2012 5:36 AM  
Any ideas? The code provided gives me an internal 500 error, so our users are not able to upload above 30Mb which is a real problem. Can you help me to understand what code I should use?

Thanks again.
James Robinson
Posts:29
Silver Member

04/11/2012 10:52 AM  
Hello,

I really need some help with this, as we have many users who need to upload files larger than 30Mb. I understand by reading that my problem is for sure in IIS7 and I need to insert the code required to extend this. However, the code that was provided gives an 500 error as was mentioned by Bienvenido Cancel in the above post. He recommended changing to manual quotes in the code.

Here was his response:
1. After a lot of investigation and trial I came across this post and immediately I pasted the code to my web.config file to find the web site unavailable due to a "500 - Internal server error". After testing I concluded that the text was correct and there were no errors but somehow the quotes were causing the problem. If someone find themselves in the same situation, replace the quotes in the code with manual quotes.

I don't understand how to do this with manual quotes. What does this mean, can someone provide the code with manual quotes for me to see?


2. One must remember to modify <system.web><httpRuntime>; also in the web.config file.

What are we to modify in these areas? I am just hoping this topic can be updated with the full code necessary to enable large upload files in IIS7 including each of the areas that needs to be changed in the webconfig.

Can someone PLEASE help me with this?

Thanks so much
Pengtsen R
Posts:13551


04/12/2012 9:27 AM  
you can give me your direct server access(remote desktop?) by email and I'll fix it for you.

thanks.

Pengtsen R
http://www.bizmodules.net
James Robinson
Posts:29
Silver Member

04/12/2012 10:35 AM  
Thank you so much for your help. I sent email to service@biz... I hope that is the right email?

Thanks
Pengtsen R
Posts:13551


04/16/2012 7:21 AM  
I'll check it and give you further reply.

Pengtsen R
http://www.bizmodules.net
Pengtsen R
Posts:13551


04/18/2012 9:37 AM  
it's ok now, it should be like this:

<security>
<requestFiltering allowDoubleEscaping="true" >
<requestLimits maxAllowedContentLength="2000000000" />
</requestFiltering>
</security>

Pengtsen R
http://www.bizmodules.net
Mat Marietta
Posts:22
Silver Member

09/17/2012 4:59 AM  
Hello! We found this link also helpful for getting our server set up correctly for large files:

http://www.telerik.com/help/aspnet-ajax/upload-uploading-large-files.html

<security >
<requestFiltering>
<requestLimits maxAllowedContentLength="1024000000" />
</requestFiltering>
</security>
Pengtsen R
Posts:13551


09/17/2012 8:01 AM  
2000000000 should be ok on most websites, but I did find on a website it only works when set to 1024000000, not sure why.

Pengtsen R
http://www.bizmodules.net
hawk007
Posts:2
New Member

09/15/2013 3:34 AM  

i try following CSS to remove commnads and the path from the RadEditor Image Manager window but if fail can you help me
-----------------------------
.RadFileExplorer .RadToolBar .icnDelete .rtbText,.RadFileExplorer .RadToolBar .icnNewFolder .rtbText
{
display:none !important;
}
-----------------

http://www.1-click-tuneup.com
Pengtsen R
Posts:13551


09/15/2013 6:22 AM  
I'm sorry I don't understand what exactly you wish to hide, can you capture a screenshot and email me?

Pengtsen R
http://www.bizmodules.net
softwareuser
Posts:3
Bronze Member

10/02/2013 6:14 PM  
On IIS7, we're able to upload files of size 33 MB only.
We'd set the web.config to allow uploads upto 100mb.

<system.webServer>
<security>
<authentication>
<anonymousAuthentication enabled="false" />
<windowsAuthentication enabled="true" useKernelMode="true">
<providers>
<clear />
<add value="NTLM" />
<add value="Negotiate" />
</providers>
<extendedProtection tokenChecking="None" />
</windowsAuthentication>
</authentication>
<requestFiltering>
<requestLimits maxAllowedContentLength="102400000" />
</requestFiltering>
</security>

<system.web>
<httpRuntime executionTimeout="99999" maxRequestLength="102400" requestLengthDiskThreshold="102400"/>
</system.web>

Not sure why we're still facing issue with uploading large files.
Any help is very much appreciated.
Pengtsen R
Posts:13551


10/03/2013 7:12 AM  
Please tell me the exact message you see when you fail to upload, a screenshot will be even better.

thanks.

Pengtsen R
http://www.bizmodules.net
softwareuser
Posts:3
Bronze Member

10/03/2013 12:28 PM  
Unable to attach the screenshot here.
We just sent you an email.
Hope to get an reply from you soon.
softwareuser
Posts:3
Bronze Member

10/03/2013 6:19 PM  
We had to set the 'maxRequestLength' for the web.config for the sharepoint site.
This resolved our issue.
You are not authorized to post a reply.
Page 1 of 212 > >>

Forums > Ultra Video Gallery > Support Questions > Upload large files in IIS 7

Copyright © 2005-2013 BizModules Contact us